Как сравнить две строки в Excel

Пользователи программы Microsoft Office Excel иногда сталкиваются с необходимостью сравнить в таблице текстовые данные. Данная опция в программе предусмотрена, в качестве результата приложение может вывести числовое или логическое значение, а также она способна просто сравнить написанное и выделить совпадения в ячейках. В данной статье рассмотрим данные возможности редактора Excel.

Инструкция

  1. Для подсчета совпадений с определенным словом или словосочетанием нужно использовать функцию программы СЧЁТЕСЛИ. Для подсчета совпадений информации в столбце А с искомой фразой установите курсор в ячейку, предназначенную для выведения результата и в строку формул впишите =СЧЁТЕСЛИ($A:$A; «Фраза»). В данном случае программа будет подсчитывать количество слова «Фраза» в столбце А.

    Формула для подсчета дат, принадлежащих февралю
    Формула для подсчета дат, принадлежащих февралю
  2. Для сравнения данных в целой колонке с одним образцом можно использовать функцию условного форматирования. Для этого впишите нужную фразу в одну из ячеек, например, в ячейку В1. Выделите колонку с информацией, в которой нужно обозначить искомую фразу, перейдите на вкладку «Главная». В разделе «Стили» нажмите иконку «Условное форматирование», укажите пункт «Правила выделения ячеек» и выберите команду «Равно».
    Команда «Равно»
    Команда «Равно»

    Будет открыто дополнительное окно, кликните по ячейке с искомой фразой и в правом выпадающем списке укажите формат выделения данного текста, нажмите ОК.

  3. Если вам нужно сравнить с образцом одновременно информацию из нескольких ячеек, вам придется использовать опции ЕСЛИ и СЦЕПИТЬ. Для соединения данных из нескольких ячеек используйте опцию СЦЕПИТЬ(А1; «и» ;B1), в данном случае программа использует текст из ячейки А1 и В1, а между ними вставит союз «и».  Для сравнения большого текста удобнее будет присвоить ячейке с данным текстом собственное имя, для этого обозначьте данную ячейку и в поле, расположенное левее строки функций, впишите для него имя, например, «Образец». После выполнения подготовки выделите ячейку, в которой должен быть результат сравнения, и впишите в него следующую формулу: ЕСЛИ(СЦЕПИТЬ(A1; «и» ;B1)=образец;1;0). В данном случае, если сравнение даст положительный результат, то в ячейке результата будет вписана единица, если совпадений обнаружено не будет – ноль. Для того, чтобы применить данную формулу к нескольким строкам таблицы, нужно ее выделить, навести на маркер в правом нижнем углу и растянуть ее на нужные строки.

Внимание! Для корректной работы программы Excel мы советуем использовать только 100% лицензионную версию, которую вы можете купить со скидкой в нашем интернет-магазине.

Видео: Функция СЦЕПИТЬ в Excel

Добавить комментарий